You are here: GSI Wiki>Linux Web>SoftwareInUsrLocal>EclipseIDE (revision 1)EditAttach

Eclipse IDE framework

Eclipse is a Java based modular IDE Framework. At the moment Version 3.2.1 is installed at GSI.

You can start Eclipse with /usr/local/bin/eclipse.

Eclipse Plugins

For installation requests see http://forum.gsi.de/index.php?th=1054.

The following plugins are currently installed:

CDT
Support for C and C++
EPIC
Perl-Support
SubClipse
SubVersion-Interface

The EclipseUML UML plugin has also been requested but its license is definitely inappropriate for a central installation at our site:
Only one EclipseUML Free Edition license (one user) per project is allowed. Exchanging of java projects created while using EclipseUML Free Edition among developers is prohibited.

-- ChristopherHuhn - 23 Nov 2006
Edit | Attach | Print version |  PDF | History: r3 < r2 < r1 | Backlinks | View wiki text | Edit WikiText | More topic actions...
Topic revision: r1 - 2006-11-23, ChristopherHuhn