Rechnen mit Zeiten

Bei der Summenbildung von Zeitangaben erhalten Sie bei einer Summe > 24 Stunden einen fehlerhaften Wert angezeigt, da Excel standardmäßig nur Zeiten bis zu 24 Stunden korrekt darstellt.

Um das Problem zu lösen, erstellen Sie ein benutzerdefiniertes Zahlenformat. Rufen Sie dazu im Menü Format - Zellen die Karteikarte Zahlen mit der Kategorie Benutzerdefiniert auf und geben im Eingabefeld Typ das Zahlenformat [h]:mm ein.

Excel kann allerdings in diesem Zusammenhang keine negativen Summen darstellen. Mit der Formel

=WENN(Z1>Z2;TEXT(Z1-Z2;"-[h]:mm");Z2-Z1)

können Sie dieses Problem umgehen, aber da die Ergebniszelle im Textformat gespeichert wird, kann danach damit nicht weitergerechnet werden. (Z1, Z2 allgemeine Form einer Zelle)


Wie rechnet man Zeitdifferenzen in Dezimalstellen um?

Zeitdifferenzen werden normalerweise in der Form hh:mm angegeben. In manchen Fällen wäre aber eine Angabe in Dezimalzahlen übersichtlicher, z.B. 1:30 = 1,5

Dies wird durch folgende Formel realisiert:
=WENN(C1<B1;24+((C1-B1)*24);(C1-B1)*24)
wobei in B1 die Start- und in C1 die Endezeit steht. Die Wenn-Abfrage braucht man für die Fälle, dass die Endezeit nach dem Tagwechsel liegt, z.B. 22:30 - 1:30

-- KerstinSchiebel - 10 Aug 2005
Topic revision: r3 - 2005-11-01, KerstinSchiebel
 
This site is powered by FoswikiCopyright © by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding GSI Wiki? Send feedback
Imprint (in German)
Privacy Policy (in German)