Wie kann man in einer Tabelle Mehrfacheinträge entfernen?

Um mehrfache Einträge in einer Tabelle zu entfernen, gehen Sie wie folgt vor:

Öffnen Sie über Daten - Filter - Spezialfilter ein Fenster, in dem die gewünschten Suchbedingungen definiert werden können. Da dieser Vorgang nicht rückgängig gemacht werden kann, ist es sinnvoll die neue Tabelle zu kopieren. Aktivieren Sie dazu die entsprechende Option und tragen in Listenbereich den Bereich, der die Werte umfasst z.B. $A$1:$A$11 und in Kopieren nach die Zielzelle ein. Aktivieren Sie die Option Keine Duplikate.


Wie kann man in einer Tabelle Mehrfacheinträge speziell formatieren?

Dafür gibt es keine vordefinierten Filter. Über eine Matrixformel (Formeleingabe mit der Tastenkombination STRG + UMSCHALT + ENTER) kann das Problem aber trotzdem gelöst werden:

=WENN(VERGLEICH(A1&B1;A&1:A$14&B$1:B$14;0)=ZEILE();"";"Duplikat")

Erläuterung:
  • Die Formel wird in eine neue Zelle eingegeben und dann in alle Zeilen kopiert. In dem o.g. Beispiel werden alle Zeilen mit "Duplikat" markiert, in deren Spalte A&B der Text zum wiederholten Mal auftritt. Untersucht wird der Bereich A1:B14.
    ALERT! In diesem Bereich dürfen keine leeren Zellen vorkommen.

  • Sollen alle mehrfach vorkommenden Zeilen berücksichtigt werden einschließlich des ersten Auftretens lautet die Formel:
    =SUMME(WENN($A1&$B1=$A$1:$A$14&$B$1:$B$14;1)) > 1

  • Möchte man die doppelten Zeilen farbig markieren, dann verwendet man o.g. Formel in Format – Bedingte Formatierung. Hier kann man spezielle Schriften, Farben etc. für die erfüllte Bedingung definieren.

-- KerstinSchiebel - 10 Aug 2005
Topic revision: r3 - 2006-04-20, KerstinSchiebel
 
This site is powered by FoswikiCopyright © by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding GSI Wiki? Send feedback
Imprint (in German)
Privacy Policy (in German)