Wie kann man in einer Tabelle das Vorkommen zweier Kriterien zählen?

Die Funktion Zählenwenn lässt nur das Zählen nach einem Kriterium zu.

Wollen Sie zählen, wie oft zwei verschiedene Kriterien gleichzeitig in einer Tabelle auftreten, müssen Sie das über eine so genannte Matrixformel erledigen.

Matrixformeln werden erzeugt durch das Eingeben einer normalen Formel und dem Abschluss durch die Tastenkombination [Strg] + [Shift] + [Enter] (geschweifte Klammern).

allgemein: {=SUMME(WENN((bereich1=("text1"))*bereich2=("text2"));1))}

In dem nachfolgenden Beispiel wird gezählt, wie oft die Kombination von "ja" im Bereich von C2 bis C64 und "ZT" im Bereich von D2 bis D64 vorkommt.

{=SUMME(WENN((C2:C64=("ja"))*(D2:D64=("ZT"));1))}


Wie kann man das Vorhandensein eines Wertes in einer anderen Spalte überprüfen?

Gegeben sind zwei Spalten mit jeweils Zahlen.

Wie kann man in eine weitere Spalte yes/no schreiben in Abhängigkeit davon, ob der Zellenwert von Spalte 1 in Spalte 2 vorkommt?

Bsp.:
   A    B
1  1    4   yes
2  2    1   yes
3  3    9   no
4  5    2   no
5  8    0   no

Lösung:

1. Variante: =WENN(ZÄHLENWENN($B$1:$B$5;A1)>0;"yes";"no")

2. Variante: =WENN(ISTFEHLER(VERGLEICH(A1;B:B;0)>=1);"no";"yes")


Wie kann man in Abhängigkeit von einer Spalte die Werte in einer anderen Spalte addieren?

Angenommen, wir haben folgenden Fall:

 A   B   C
Bez.    Anzahl
x       1
y       2
z       3
y       9
y       8
z       6
x       3
x       5
x       8
x       7
x       3
y       6
z       10

Teilsumme x: 27
Teilsumme y: 25
Teilsumme z: 19

Das heißt, Sie wollen Teilsummen für die einzelnen Bezeichnungen ermitteln (eine sogenannte "bedingte Summe"). Auch hierfür benötigen Sie eine Matrix-Formel (s.o.), in der die Eingabe einer Formel mit der Tastenkombination [Strg] + [Shift] + [Enter] (geschweifte Klammern) abgeschlossen wird (nicht die geschweiften Klammern direkt eintippen!). Diese Formel sieht folgendermaßen aus:

{=SUMME(WENN((A2:A14="x");C2:C14))}

So lassen sich auch Bedingungen über mehrere Spalten eingeben. Angenommen, in der Spalte B stehen auch Werte drin zwischen a und f, und Sie wollen nur die Zahlen addieren, die in Spalte A ein "x" und in Spalte B ein "b" enthalten. Dann sieht die Formel folgendermaßen aus:

{=SUMME(WENN((A2:A14="x")*(B2:B14="b");C2:C14))}

Die einzelnen Bedingungen werden hierbei miteinander multipliziert.

-- KerstinSchiebel - 10 Aug 2005
Topic revision: r4 - 2006-02-17, BirgittKarlson
 
This site is powered by FoswikiCopyright © by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding GSI Wiki? Send feedback
Imprint (in German)
Privacy Policy (in German)