Handling of CS.start.vi and Building of Applications.

Due to some changes in LabVIEW for versions newer than 2010, some changes had to be implemented within the CS, which affect both: Building of new applications and executing the CS from the development environment.

Building of new applications

The following picture shows a small part of the CS_Start.vi (you find it on the lower-left side if you open the block diagram).


Including Classes in CS 3.30

If you would like to create a new build specification you have to modify the CS_Start.vi here. In this case structure you have to insert all Contents.VIs which you want to compile into an application. The screenshot above shows that the CS_Contents_Main.vi (the vi on the left side) will be included in all builds, whereas the CS_Contents_DSCIntProc.vi will only be included if the ActualBuild is equal to CS_DSCIntProc. This SystemVariable "ActualBuild" will always be automatically set just before the build process to the name of the build specification.


Screen of the Build Specifications

So, make sure both names are identically!

Important is also that you execute the "Pre-Build Action.vi" and the "Post-Build Action.vi" just before and after the build process. This is already configured in the default build specifications. If you want to create a new one, just copy a default one!

Using of new classes within the developer environment

Also in the developer environment all classes have to be loaded in memory prior to their excecution. So if you want to test a new class you have to include its Contents.vi in the Default Case of the ConditionalDisableStructure (see first picture above). Also all additional utility programs (LV2012Migrate utility, Inherit class tool, ...) need to know all classes. These two steps can be combined within the following procedure:

Always include your specific Contents.vi in the CS_Contents_User.vi.

Error Message when you forgot to include your Contents.vi

If you forgot to include your Contents.vi in the memory space the CS will unfortunately not give you a proper error message. Instead you get the error "Process does not exist" once you try to create an object.

-- DennisNeidherr - 03 Sep 2013
Topic revision: r2 - 2013-09-11, DennisNeidherr
 
This site is powered by FoswikiCopyright © by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding GSI Wiki? Send feedback
Imprint (in German)
Privacy Policy (in German)