Software in /usr/local

The central /usr/local/ volume has been discontinued after DebianSqueeze. Please take a look at SoftwareInCvmfs instead.

The old volume is still available at /SAT/usrlocal but most probably contains nothing that is still useful.

Contrary to its naming /usr/local/ is a volume mounted from a central server all over the LinuxFarm.

Software installed here is either
  • not available as a debian package (or shall not be converted),
  • not managed by a member of the LinuxGroup
  • needs to be available in multiple versions in parallel
  • pollution from the past

The state of these packages is in general unknown, the LinuxGroup cannot be held responsible for missing /updated libraries et al.


Name Command Version Location Contact Description
AliRoot aliroot multiple versions /usr/local/pub/debian*/gcc*alice/AliRoot KilianSchwarz  
http://www.adobe.com/products/flashplayer/ Adobe (prev. Macromedia) Flash player n/a 9.0.124 /usr/local/WWW/Browser/Plugins/flash_player.../ ChristopherHuhn Flash plugin for various browsers
http://www.ansys.com/ ANSYS ansys 11.0 /usr/local/ansys/ ChristopherHuhn  
Eclipse eclipse 3.1.2 /usr/local/eclipse/ ChristopherHuhn  
SATAN/GD gd, graf 9712e /usr/local/mk/ MichaelKraemer Login script gdlogin
Geant4   multiple versions /usr/local/pub/debian*/gcc*/sim/ KilianSchwarz  
IDL idl, idlde 8.0 (32- and 64bit versions), 5.6 (for legacy apps) /usr/local/lpp/idl.80/ ChristopherHuhn  
Intel Compiler Suite icc, idb, ... 10.0 /usr/local/Intel/ LinuxGroup  
LabVIEW labview 7.1 /usr/local/labview/ HolgerBrand (H.Brand@gsi.de)  
Mathematica mathematica 8.0 /usr/local/lpp/mathematica GabrieleHorst, ChristopherHuhn  
mpich2   2 /usr/local/mpich2 MariusSchollmeier (m.schollmeier@gsi.de)  
PortlandCompiler pgcc, pgf, ... 6.1.3 /usr/local/lpp/pig-6.1.3 EdmarStiel, PeterMalzacher Portland Group's PGI Compiler Suite
http://www-w2k.gsi.de/root/ ROOT root http://www-w2k.gsi.de/root/currently_installed_versions.htm multiple versions /usr/local/pub/debian*/gcc*/rootmgr/ JoernAdamczewski, KilianSchwarz  
SAP-GUI sap, sapgui 6.3 r2 /usr/local/sap/ TilmanKirchhoff (T.Kirchhoff@gsi.de), JohannesHeilmann  

info Adobe Acrobat is not longer available for Linux, see here.

Software obsoleted by Debian packages in the meantime

Name Command Latest Version Location Contact Replaced by
http://www.mozilla.org Mozilla mozilla 1.7.3 /usr/local/WWW/Browser/ ChristopherHuhn DebPkg:mozilla (Version 1.7.8), DebPkg:mozilla-firefox (Version 1.0.4), DebPkg:mozilla-thunderbird (Version 1.0.2)
http://www.opendx.org/ OpenDX (Open Visualization Data Explorer) dx 4.1.0 /usr/local/dx/ EdmarStiel DebPkg:dx (Version 4.3.2)
TeX latex, ... 3.14159 (teTeX 1.0) /usr/local/teTeX/ KerstinSchiebel DebPkgTexliveTeXliveDebianPackages (Version 2005)

-- ChristopherHuhn -- 2005 - 2016
Topic revision: r34 - 2016-11-14, ChristopherHuhn - This page was cached on 2020-12-01 - 05:59.

This site is powered by FoswikiCopyright © by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding GSI Wiki? Send feedback | Imprint (german) | Privacy Policy (german)